SCADA Vulnerabilities & Exposures (SVE)

CRITIFENCE® SCADA Vulnerabilities and Exposures Database (SVE)

[SVE-804689870] PHOENIX CONTACT mGuard Device Manager

Date Type Platform Author EDB-ID CVE-ID OSVDB-ID Download App SIS Signature
2017-09-19OtherPHOENIX CONTACTPHOENIX CONTACT reported these vulnerabilities to CERT@VDE. CERT@VDE coordinated these vulnerabilities with ICS-CERT. N/ACVE-2017-1010 CVE-2017-1011 CVE-2017-1007 CVE-2017-1011 CVE-2017N/AN/AN/A

Source

						
							
								
#
# PHOENIX CONTACT mGuard Device Manager
#


### VULNERABLE VENDOR
PHOENIX CONTACT


### VULNERABLE PRODUCT
mGuard Device Manager



### RESEARCHER
PHOENIX CONTACT reported these vulnerabilities to CERT@VDE. CERT@VDE coordinated these vulnerabilities with ICS-CERT.



### AFFECTED PRODUCTS

The following versions of mGuard Device Manager, a device management software for mGuard devices, are affected:

mGuard Device Manager 1.8.0 and older.



### IMPACT

Successful exploitation of these vulnerabilities could allow unauthorized remote access, modification of data, and may allow remote and local users to gain elevated privileges.



### VULNERABILITY OVERVIEW

IMPROPER ACCESS CONTROL CWE-284
Improper Access Control vulnerabilities have been reported for Oracle Java SE, which is provided with PHOENIX CONTACT FL MGUARD DM.
According to Oracle, the supported Java versions affected by these vulnerabilities are Java SE: 8u131, 7u141 and 6u151, Java SE Embedded: 8u131, and JRockit: R28.3.14.
PHOENIX CONTACT provided FL MGUARD DM 1.8.0 for Windows with Java SE 8u131.
CVE-2017-10102, CVE-2017-10116, CVE-2017-10078, CVE-2017-10115, CVE-2017-10118, CVE-2017-10176, CVE-2017-10198, CVE-2017-10135, CVE-2017-10053, CVE-2017-10108 have been assigned to these vulnerabilities.
A CVSS v3 base score of 9.0 has been assigned; the CVSS vector string is (AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H)


For more information on these vulnerabilities, please refer to sources cited at these locations:
Published advisory of CERT@VDE:
https://cert.vde.com/de-de/advisories/vde-2017-002
(link is external)

Oracle Critical Patch Update Advisory report:
http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
(link is external)




### BACKGROUND

Critical Infrastructure Sectors: Communications, Critical Manufacturing, Information Technology
Countries/Areas Deployed: Worldwide
Company Headquarters Location: Germany




### MITIGATION

PHOENIX CONTACT recommends that all users of the affected product on Windows should update to at least Version 1.8.0.1. The update can be performed by simply executing the installer for Version 1.8.0.1 on a Windows system where the product is installed in Version 1.8.0. The installer is available for download on the product page, in section "Software" on the Downloads tab at the following location:

https://www.phoenixcontact.com/online/portal/us?uri=pxc-oc-itemdetail:pid=2981974


For more information please refer to the document "How to upgrade mGuard device manager" downloaded with the installer.

PHOENIX CONTACT recommends that all users of the affected product on Linux should update Java to the latest version. When using the packet source delivered by PHOENIX CONTACT on Ubuntu, this is simply done by using the software updater of the operating system.